2008年12月22日 星期一

Hackintosh on SONY VAIO VGN-SZ28TP

Summary

|SONY VAIO SZ28TP+OSX86 10.5.5 (iDeneb v1.3)
|Intel Centrino Duo CPU T2500 @ 2.00GHz, 1.00GHz 1.5GB RAM| Working
|nVidia Geforce Go7400 Graphics| Not Work
|GMA945 Intel Graphics| Working w/DisplayConfigX @ 1280x800
|SigmaTel HD Audio| Working by Taruga's Patcher + STAC7661 Codec| Working
|Optical Drive:MATSHITA UJ-852S| Working
|Bluetooth TOSHIBA| Working but can not switch OFF
|Intel® PRO/Wireless 3945ABG| Not Work
|Broadcom 4311 802.11g mini PCI-E Wireless| Working as Native Airport
|Marvell Yukon 88E8036 PCI-E Fast Ethernet Controller| Working by modified AppleYukon.kext
|Sony VGP-VCC2 Webcam| Not Work
|PCMCIA Cardbus| Working by PCCard.10.5.2 beta 3 Driver
|Fingerprint scanner| Not Work in UPEK Protect Suite

I've installed an OSX86 10.5.5 (iDeneb v1.3) on my SONY VAIO VGN-SZ28TP laptop for a couple of months, it works fine so far, for those components which are not work, I've been searching for any possibility to make them work, but failed. Now I try to recap the process of installation, write them done for reference!

nVidia Geforce Go7400 graphics is not work @ correct resolution on SONY VAIO so far, but I heard it works for external LCD, I didn't test them.

Intel GMA945 (Vendor ID: 8086/Device ID: 27A2)
Intel GMA945 graphics works by AppleIntelIntegratedFramebuffer.kext 1.4.18 from Tiger or 1.4.20 from Leopard, both version did not support brightness control, however, you will get maximum LCD brightness on version 1.4.20, version 1.4.18 provids a dimmer LCD brightness. On my laptop, I can change the LCD birghtness when booted into Windows XP and keep the LCD brightness setting after rebooted into OSX. I bought DisplayConfigX to make it work a 1280x800.

The original AppleIntelGMA950.kext from iDeneb v1.3 is not work, I have to copy the AppleIntelIntegratedFramebuffer.kext from older version.

SigmaTel HD Audio 7661 (Vendor ID: 8384/Device ID: 7661)
Use AppleHDAPatcher v1.20 to patch.
Drag SonyStac7661.txt into AppleHDPatcher install, I believe the key point is the code text file.

The Intel 3945ABG wireless driver for OSX86 is still under development, I already giveup to make it work, instead of, I bought a Broadcom 4311 802.11g mini PCI-E wireless module from Internet, it works a native Airport, perfect!

Marvell Yukon (Vendor ID: 11AB/Device ID: 4351)
Modify /System/Library/Extensions/AppleYukon2.kext/Contents/Info.plist
find and modify the following paragraph:
Yukon-88E8053
IOPCIPrimaryMatch
0x436211AB --> 0x435111AB

PCMCIA Card (Vendor ID: 104C/Device ID: 8039 & 803B)
Use PCCard.10.5.2 beta 3 kext
Modify /System/Library/Extensions/IOPCCardFamily.kext/Contents/MacOS/IOPCCardFamily by hexeditor,
find & modify string "4C103980" for the multiple card reader

I also have tried to install the Protector Suite fro UPEK, however, the software can not identified the fingerprint scanner, some people said it works on Dell XPS.

Using a native Windows XP partition as a "BootCamp" partition on VMWare Fusion.

VMWare is not seeing the windows partition as a "BootCamp" partiton.

1) Install VMWare.

2) Open terminal and type:

$ sudo fdisk -e /dev/rdiskx

where x is the number of your hd where you have the two systems.
type:
> print

here you will have a list of your partitions. Please proceed ONLY if you see the HFS+ partition flagged with the * symbol.
type:
> flag X

where X is the number of the windows partition you want to use with vmware.

type:
> write

type "y" and enter.

Do not exit fdisk as you will need it just in a few minutes.

3) launch vmware and you'll be pleased to see that you now have a bootcamp boot option. Follow the program instructions.

4) When you have finished to install everything and play a bit with the new toy exit VMWare shutting the machine down.

5) Go to the open terminal window and type:

> flag X
where X is the number of the partition the was flagged before you changed it (the HFS+ boot partition).

type:
> write
y
> exit

6) Open vmware and verify that the BootCamp boot option is still there (as it was for me).

7) Try to reboot mac os (it should be all ok!

DONE! Mo王子

2 則留言:

John So 提到...

Video Card works, check here.
Wifi also works but with Snow leopard only.
http://blog.johnso.org/2009/12/asus-w7j-osx86-settings.html

Mo 爸::菲尼克斯:: 提到...

Thanks for the update...
However, I've sold out my Sony VAIO SZ280, and bought an Apple Macbook Pro...:-)